• Home
  • Computação em Nuvem
  • Marketing Digital
  • Destaque
  • Leia
Uberdan Agnelo
  • Home
  • Computação em Nuvem
  • Marketing Digital
  • Destaque
  • Leia
No Result
View All Result
  • Home
  • Computação em Nuvem
  • Marketing Digital
  • Destaque
  • Leia
Subscribe
No Result
View All Result
Uberdan Agnelo
No Result
View All Result
Home Leia

Comandos e shell bash LPI – 1

user by user
março 12, 2026
in Leia
0
Share on Facebook
Share on Twitter

Comandos:

cd – = envia para o ultimo diretório que visitou

Related articles

Guia de Estudos para Concurso Público de Indaiatuba – Legislação

Resumo de estudo para Concurso Público CPMH 003/2025 – Analista de redes e infra

env = variáveis de ambiente do sistema

pwd = diretório que vc esta

alias hora=’date’ – cria um apelido (hora) para o comando date

unalias = remove apelido

VARIAVEL = “10”

ECHO $VARIAVEL = aparace 10

ECHO VARIAVEL = aparece VARIAVEL

 

comandos com espaço não são gravados no History

para setar uma variável use o export  $HISTSIZE = 1000 (para já valer para todo o ambiente, quando reiniciar perde)

set $HISTSIZE = 1000 (antigo) é igual $HISTSIZE = 1000

 

cut – recorta parte do texto, veja o exemplo abaixo:

root@mafia:/home/uberdan# cat /etc/os-release (arquivo original)
PRETTY_NAME=”Debian GNU/Linux 8 (jessie)”
NAME=”Debian GNU/Linux”
VERSION_ID=”8″
VERSION=”8 (jessie)”
ID=debian
HOME_URL=”http://www.debian.org/”
SUPPORT_URL=”http://www.debian.org/support”
BUG_REPORT_URL=”https://bugs.debian.org/”

root@mafia:/home/uberdan# cat /etc/os-release | cut -d “_” -f1 (antes do undeline)
PRETTY
NAME=”Debian GNU/Linux”
VERSION
VERSION=”8 (jessie)”
ID=debian
HOME
SUPPORT
BUG

root@mafia:/home/uberdan# cat /etc/os-release | cut -d “_” -f2 (depois do underline)
NAME=”Debian GNU/Linux 8 (jessie)”
NAME=”Debian GNU/Linux”
ID=”8″
VERSION=”8 (jessie)”
ID=debian
URL=”http://www.debian.org/”
URL=”http://www.debian.org/support”
REPORT

Mostrar só o amd64 do comando uname -a

root@mafia:/home/uberdan# uname -a
Linux mafia 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt20-1+deb8u3 (2016-01-17) x86_64 GNU/Linux

root@mafia:/home/uberdan# uname -a | cut -d “#” -f1 | cut -d “-” -f3
amd64

 

Arquivo bora.sh // mostra a hora e o usuaio e desliga o PC

#!/bin/bash

HORA=`date +%H:%M`

echo -n “Agora sao $HORA.”
echo ” Hora de ir embora $USER!”
echo “”

shutdown -h now

exit

 

Exemplo2

#!/bin/bash

#verifica usuario logado
USUARIO=`whoami`

#exibir Variavel usuario
echo “Usuario logado é:” $USUARIO

 

Exemplo3

#!/bin/bash

DIR_ATUAL=`pwd`

echo “O diretorio atual é ” $DIR_ATUAL
echo “Qual o diretorio que deseja lista? ”
read DIR_LIST

cd $DIR_LIST
pwd
sleep 3
ls
exit

 

Visualizar tela do terminal = shift + page up ou page down

comando direto ou PIPE – | more consegue ler o arquivo — só desce com enter linha a linha e espaço tela a tela

q – para sair

comando direto ou PIPE – | less consegue ler o arquivo — só desce com enter linha a linha e espaço tela a tela porem dá para usar seta pra cima para voltar

q – para sair

 

root@mafia:/home/uberdan# less /etc/protocols | grep -i “ipv6” | wc  – filtra ipv6 tanto maiúsculo e minusculo e conta as linhas
8 65 416
root@mafia:/home/uberdan# less /etc/protocols | grep “ipv6” | wc – filtra ipv6 só minusculo e conta as linhas
6 48 290
root@mafia:/home/uberdan# less /etc/protocols | grep “ipv6” | nl – filtra ipv6 só minusculo e numera linhas
1 ipv6 41 IPv6 # Internet Protocol, version 6
2 ipv6-route 43 IPv6-Route # Routing Header for IPv6
3 ipv6-frag 44 IPv6-Frag # Fragment Header for IPv6
4 ipv6-icmp 58 IPv6-ICMP # ICMP for IPv6
5 ipv6-nonxt 59 IPv6-NoNxt # No Next Header for IPv6
6 ipv6-opts 60 IPv6-Opts # Destination Options for IPv6
root@mafia:/home/uberdan# less /etc/protocols | grep -i “ipv6” | nl – filtra ipv6 tanto maiúsculo e minusculo e numera linhas
1 hopopt 0 HOPOPT # IPv6 Hop-by-Hop Option [RFC1883]
2 ipv6 41 IPv6 # Internet Protocol, version 6
3 ipv6-route 43 IPv6-Route # Routing Header for IPv6
4 ipv6-frag 44 IPv6-Frag # Fragment Header for IPv6
5 ipv6-icmp 58 IPv6-ICMP # ICMP for IPv6
6 ipv6-nonxt 59 IPv6-NoNxt # No Next Header for IPv6
7 ipv6-opts 60 IPv6-Opts # Destination Options for IPv6
8 mobility-header 135 Mobility-Header # Mobility Support for IPv6 [RFC3775]

Listar apenas diretórios

ls -lah /etc/ | grep ^d — grep ^d mostra as linhas que começam com d

Mostrar apenas as 3 primeiras linhas (-n 3)

root@mafia:/home/uberdan# head -n 3 /etc/protocols
# Internet (IP) protocols
#
# Updated from http://www.iana.org/assignments/protocol-numbers and other

Mostrar apenas as 3 ultimas linhas (-n 3)

root@mafia:/home/uberdan# tail -n 3 /etc/protocols
shim6 140 Shim6 # Shim6 Protocol [RFC5533]
wesp 141 WESP # Wrapped Encapsulating Security Payload
rohc 142 ROHC # Robust Header Compression

tail -f = observa o arquivo em tempo real

kill -9 = mata da hora

kill -15 = mata educadamente

 

Alterar prioridade de execução de um processo:

Quando o processo ja existir o comando é renice (renice -10 -p 2997) -p de processo ID

Quando o processo não existe o comando é nice (nice -n 15 htop) -n para prioridade

quanto maior o numero menor a prioridade 20 e -20 sera maior a prioridade

 

Editor VI

por números em linhas :set nu <> tirar :set nonu

:syntax on – deixar o texto com COR

:22 – pula para linha 22

dd – deleta linha

p – cola

cc – corta

:u – desfaz alteração

/palavra – Busca palavra no texto root por ROOT

:%s/root/ROOT/g – localizar e substituir

:19s/systemd\ Time\ Synchronization/systemd\-Time\-Sync/g >> muda linha 19 tira os espaço e substitui por –

:wq – gravar e sair

:q! – sair sem salvar

V – visualizar seleciona >> Shift U – tudo maiúsculo >> Shift u – tudo minusculo

 

Adicionar Usuário (feriado) de forma Completa

adduser feriado (mais completo)

useradd feriado (cria usuário sem senha e conta bloqueada, alem de bash sh)

 

Travar /etc/passdw e /etc/shadow

pwunconv (travar)

pwconv (destravar)

 

Slow lois

Tags: comandosshell
user

user

Related Posts

Guia de Estudos para Concurso Público de Indaiatuba – Legislação

by user
março 12, 2026
0

Este documento abrange os principais pontos da Lei Orgânica do Município de Indaiatuba (LOMI), da Lei Complementar nº 45/2018 (Estatuto dos Servidores Públicos Municipais) e da...

Resumo de estudo para Concurso Público CPMH 003/2025 – Analista de redes e infra

by user
março 12, 2026
0

1. Redes de Computadores Modelos OSI e TCP/IP Os modelos OSI (Open Systems Interconnection) e TCP/IP (Transmission Control Protocol/Internet Protocol) são as arquiteturas fundamentais para entender...

Material de estudo Concurso ADM Unicamp: Legislação Trabalhista e Previdenciária

by user
março 12, 2026
0

Este material foi elaborado para fornecer uma visão abrangente sobre os principais tópicos relacionados à legislação trabalhista e previdenciária, jornada de trabalho, extinção do contrato de...

Material básico de estudo de Português para concurso

by user
março 12, 2026
0

1. Ortografia e Formação de Palavras Ortografia: Regras de escrita correta; uso do hífen; palavras com e sem acento gráfico. Estrutura e formação das palavras: Identificação...

A gestão financeira estratégica em Tecnologia da Informação

by user
março 12, 2026
0

A gestão financeira no setor de tecnologia da informação (TI) é uma peça fundamental para o sucesso das empresas modernas. A área financeira tem evoluído constantemente...

Next Post

Liberar acesso irrestrito à internet usando SSH

Aula sobre FreeBds – Atualização ports (programas) e versão

Aula FreeBsd – permissões

CATEGORIES

  • Blog
  • Computação em Nuvem
  • Destaque
  • Leia
  • Marketing Digital

RECOMMENDED

Leia

Agilidade e DevOps

março 12, 2026
Leia

ExOs ou Organizações Exponenciais o que é isto?

março 12, 2026

TAGS

academico certifica cisco comandos Computação em Nuvem conceitos configura Containers debian destroy dinamico Docker estratégias de mídia estudos etherchannel fatec freebsd historia hortolandia IaaS init Inovação Digital jogos Kubernetes linux Marketing Digital modulo1 modulo2 modulo3 O que é uma Vlan O que é VRF PaaS plan praticas redes redes virtuais roteadores roteamento Saas spanning switchs Terraform trunk virtualização vlans
No Result
View All Result
  • Home
  • Computação em Nuvem
  • Marketing Digital
  • Destaque
  • Leia

© 2026 JNews - Premium WordPress news & magazine theme by Jegtheme.