Pular para o conteúdo

Configuração de Spanning-Tree, EtherChannel, HSRP e VTP

  • por

Configurar o EtherChannel

Configure o EtherChannel no SW1 => Associe as interfaces FastEthernet0/21 e 0/22 ao grupo Port-Channel 1 e ative o Etherchannel manualmente utilizando o modo “on” => Associe as interfaces FastEthernet0/23 e 0/24 ao grupo Port-channel 2 e ative o Etherchannel manualmente utilizando o modo “on”

interface Port-channel 1
switchport mode trunk
exit
interface Port-channel 2
switchport mode trunk
exit
interface FastEthernet0/21
switchport mode trunk
channel-group 1 mode on
exit
interface FastEthernet0/22
switchport mode trunk
channel-group 1 mode on
exit
interface FastEthernet0/23
switchport mode trunk
channel-group 2 mode on
exit
interface FastEthernet0/24
switchport mode trunk
channel-group 2 mode on
exit

 

Configure o EtherChannel no SW2 => Associe as interfaces FastEthernet0/21 e 0/22 ao grupo Port-Channel 2 e ative o Etherchannel manualmente utilizando o modo “on” => Associe as interfaces FastEthernet0/23 e 0/24 ao grupo Port-channel 3 e ative o Etherchannel manualmente utilizando o modo “on”

interface Port-channel 1
switchport mode trunk
exit
interface Port-channel 2
switchport mode trunk
exit
interface FastEthernet0/21
switchport mode trunk
channel-group 1 mode on
exit
interface FastEthernet0/22
switchport mode trunk
channel-group 1 mode on
exit
interface FastEthernet0/23
switchport mode trunk
channel-group 2 mode on
exit
interface FastEthernet0/24
switchport mode trunk
channel-group 2 mode on
exit

 

Configure o EtherChannel no SW3 => Associe as interfaces FastEthernet0/21 e 0/22 ao grupo Port-Channel 3 e ative o Etherchannel manualmente utilizando o modo “on” => Associe as interfaces FastEthernet0/23 e 0/24 ao grupo Port-channel 1 e ative o Etherchannel manualmente utilizando o modo “on”

interface Port-channel 1
switchport mode trunk
exit
interface Port-channel 2
switchport mode trunk
exit

interface FastEthernet0/21
switchport mode trunk
channel-group 1 mode on
exit
interface FastEthernet0/22
switchport mode trunk
channel-group 1 mode on
exit
interface FastEthernet0/23
switchport mode trunk
channel-group 2 mode on
exit
interface FastEthernet0/24
switchport mode trunk
channel-group 2 mode on

 

Configurar VLANs com VTP e links Trunk

Configure os três switches para participarem do domínio VTP “cisco.com” => Certifique que o SW1 está operando em modo SERVER do VTP e configure os demais switches
para operar em modo CLIENT

SW1 vtp domain cisco.com
vtp mode server

SW2 vtp domain cisco.com
vtp mode client

SW3 vtp domain cisco.com
vtp mode client

Crie três VLANs em SW1, conforme informações abaixo:
VLAN 10 (com o nome RH)
VLAN 20 (com o nome Compras)
VLAN 30 (com o nome Engenharia)

vlan 10
name RH
exit
vlan 20
name COMPRAS
exit
vlan 30
name ENGENHARIA
exit

No switch SW3, atribua à VLAN 10 a porta FastEthernet 0/1 e configure-a como modo de acesso. Para a VLAN 20, atribua a porta FastEthernet 0/2 e configure-a como modo de acesso.  Para a VLAN 30, atribua a porta FastEthernet 0/3 e configure-a como modo de acesso

interface FastEthernet0/1
switchport access vlan 10
switchport mode access
exit
interface FastEthernet0/2
switchport access vlan 20
switchport mode access
exit
interface FastEthernet0/3
switchport access vlan 30
switchport mode access
exit

 

Configure os links Trunk => Nas interfaces Port-channel 1 e 2 nos três switches => Nas interfaces GigabitEthernet 0/1 de SW1 e SW2

interface Port-channel 1
switchport mode trunk
exit
interface Port-channel 2
switchport mode trunk
exit

SW1 => interface GigabitEthernet0/1
switchport mode trunk
exit

SW2 => interface GigabitEthernet0/1
switchport mode trunk
exit

 

Habilite as interfaces GigabitEthernet 0/0 do roteador R1 e R2. Em seguida, em cada interface GigabitEthernet 0/0, crie três subinterfaces, uma para cada VLAN, de forma que o  roteamento entre VLANs aconteça. Por fim, em cada subinterface, configure o encapsulamento DOT1Q, juntamente com o ID de VLAN, e atribua o segundo endereço IP + máscara de cada VLAN para R1 e o terceiro endereço IP + máscara de cada VLAN para R2, conforme esquema de endereçamento descrito na topologia

R1

interface GigabitEthernet0/0
no shutdown
exit
interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.2 255.255.255.0
standby 1 ip 192.168.10.1
standby 1 priority 150
standby 1 preempt
exit
interface GigabitEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.20.2 255.255.255.0
standby 1 ip 192.168.20.1
standby 1 priority 150
standby 1 preempt
exit
interface GigabitEthernet0/0.30
encapsulation dot1Q 30
ip address 192.168.30.2 255.255.255.0
standby 1 ip 192.168.30.1
standby 1 priority 150
standby 1 preempt
exit

interface Serial0/0/0
no shutdown
ip address 200.0.0.1 255.255.255.252

R2

interface GigabitEthernet0/0
no shutdown
exit
interface GigabitEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.3 255.255.255.0
exit
interface GigabitEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.20.3 255.255.255.0
exit
interface GigabitEthernet0/0.30
encapsulation dot1Q 30
ip address 192.168.30.3 255.255.255.0
exit

interface Serial0/0/0
no shutdown
ip address 200.0.0.5 255.255.255.252

Definir as configurações do Spanning-Tree

Defina a root bridge e a root secundária para a VLAN 10 => Configure SW1 como root bridge alterando manualmente a prioridade para 0 => Configure SW2 como root secundária alterando manualmente a prioridade para 4096

SW1 – spanning-tree vlan 10 priority 0

SW2 – spanning-tree vlan 10 priority 4096

Defina a root bridge e a root secundária para a VLAN 20 => Configure SW2 como root bridge alterando manualmente a prioridade para 0 => Configure SW3 como root secundária alterando manualmente a prioridade para 4096

SW2 – spanning-tree vlan 20 priority 0

SW3 – spanning-tree vlan 20 priority 4096

Defina a root bridge e a root secundária para a VLAN 30 => Configure SW3 para ajustar automaticamente a prioridade de forma que o mesmo se torne a root bridge => Configure SW1 para ajustar automaticamente a prioridade de forma que o mesmo se torne a root secundária

SW3 – spanning-tree vlan 30 root primary

SW1 – spanning-tree vlan 30 root secondary

Configurar o HSRP nos gateways

Configure o HSRP =>  No roteador R1 defina, em cada subinterface, o endereço IP virtual de cada uma das VLANs e altere sua prioridade para 150 para que ele seja o roteador ativo. Habilite o Preemption em R1, para forçar uma nova eleição caso R1 fique ativo (UP) após já ter ocorrido a eleição do Active Router

R1

interface GigabitEthernet0/0.10
standby 1 ip 192.168.10.1
standby 1 priority 150
standby 1 preempt
exit
interface GigabitEthernet0/0.20
standby 1 ip 192.168.20.1
standby 1 priority 150
standby 1 preempt
exit
interface GigabitEthernet0/0.30
standby 1 ip 192.168.30.1
standby 1 priority 150
standby 1 preempt
exit

No roteador R2 defina, em cada subinterface, o endereço IP virtual de cada uma das VLANs

interface GigabitEthernet0/0.10
standby 1 ip 192.168.10.1
exit
interface GigabitEthernet0/0.20
standby 1 ip 192.168.20.1
exit
interface GigabitEthernet0/0.30
standby 1 ip 192.168.30.1
exit

O hostname já está configurado nos roteadores e nos switches, e também já existem rotas configuradas em R1, R2 e no roteador ISP, situado na nuvem através do protocolo de  roteamento dinâmico EIGRP.

SW1

router eigrp 1
network 192.168.10.0
network 192.168.20.0
network 192.168.30.0
network 200.0.0.0 0.0.0.3

SW2

router eigrp 1
network 192.168.10.0
network 192.168.20.0
network 192.168.30.0
network 200.0.0.4 0.0.0.3